Dragonfly Q&A

What version of g++ was used to create game0?

0 like 0 dislike

I am attempting to compile on debian 8 with g++ 4.9.2, and I am getting errors related to std library functions. Using SFML 2.4 from the their website as my package manager doesn't have version 2.4.

 

Linked is a pastebin of the result.

http://pastebin.com/eB5c03MZ

Dragonfly version 4.2
asked Aug 26, 2016 by gahayes

1 Answer

0 like 0 dislike
 
Best answer
Well, game0 is what you are creating.  But I think you mean what version of g++ is used to create Dragonfly.  libdragonfly-linux64.a was created via a "clean" install on Ubuntu 16:

<p><code>gcc version 5.4.0 20160609 (Ubuntu 5.4.0-6ubuntu1~16.04.2)</code>

<p>You might try the libdragonfly-linux64-ubuntu14.a version that is also included.

But I think the main problem is your g++ version is rather old.
answered Aug 26, 2016 by claypool
selected Aug 26, 2016 by gahayes
Switching to the ubuntu libs got rid of most of the errors, but still were some so I upgraded g++ and totally broke my installation.

Using VS2015 for now.
More information about Dragonfly can be found on the Dragonfly Home Page.
...